Homey Community Forum

Downgrade App

#1

Is there a way to downgrade an App to the previous version?

They added the ‘non automatic update’ feature now for the apps, which is great. But it is too late for the KAKU app, which doesn’t work anymore for me since the last update.

Where can I find older App versions and how to install them on Homey (for a dummy)?

Thanks!

#2

This is not supported officially. But if you have the Sourcecode of the previous release (via github) you may continue with the old app via a cli installation. For using CLI installations there are a few posts here, just need to search for it.

#3

Don’t know what you mean with “non-automatic update feature” cause what I think you mean has existed for a long time already.

If Kaku doesn’t work please always PTP first (pull the plug). > 90% of the time it’s solved then.

The last KaKu version is 4.1.13, dated 31-1-2019. The source can be found here. There are no other mentions of the latest version not working in the last 1.5 month and KaKu is one of the most used apps on Homey. So my guess is there’s nothing wrong with the app but it’s something at your place.

There’s also a beta-version of the KaKu-app, the source can be found here. It can be installed through the app-store.

if you want to go back in time, you can go through https://github.com/athombv/nl.klikaanklikuit/commits/development and install older versions by the CLI but as mentioned it’s very unlikely the app is the issue…

If PTP doesn’t help replace the battery’s on your devices. KaKu-devices are known to flood the 433 spectrum with nonsense if they’re running out of battery’s and render other devices useless…

1 Like
#4

Thanks. You mean reboot Homey?

I have tried everything. Reprogram Homey from scratch. Reprogram all KAKU devices. The KAKU devices are wall plugged, so no battery AFAIK.

The “Invalid Device Data” issue is a well known problem that many users had and have since august, it keeps on coming back. Primarily with the ACD-1000 devices. And pretty much zero support from Athom (as usual).

After searching the forum, I found a video explaining how to place back old versions of the App. I was successful putting a version back from January that I found on Github. Everything works fine now, except the ASUN-650 (tv lift).

So, this confirms the app versions are giving issues. Seems they fix one thing and bring back another issue and don’t test well enough before releasing. Shouldn’t happen with Athom managed apps.

#5

Pulling the plug is not the same as reboot (hence the difference in name). In a reboot there power is kept on Homey while a PTP completely empties all capacitors. When there’s an invalid device data, a reboot might be enough but that’'s not what you described: you said the KaKu app doesn’t work anymore which is something completely different. Did the KaKu app crash or didn’t devices react anymore?

As for the ACD-1000 : works perfectly for me and use it on a daily basis. So I’d say it’s not Homey but something at your place and probably we’re both partly right :wink:

#6

Yes, you are right. The app ‘works’, but after reprogramming the ACD-1000, it will show up an exclamation mark for the device with the message “invalid_device_data”. This usually happens after a few hours (initially they work, but after a few hours they stop working).

Also learning/pairing the KAKU devices only works with learning from the remote. When trying to add through the ‘generate new signal’ method, Homey (or the App) doesn’t pick up the signal at all.

#7

Now I’ve manually installed v4.1.1 which I found on Github. No problems at all with this version. So they have changed something in the code that causes it to stop working properly.