Homey Community Forum

Evohome switch electric heater using homey

The Evohome by default does not support switching electric heaters.
This is where homey comes in!
Requirements:

  1. A honeywell T87RF2025 sensor (or other evohome compatible sensor)
  2. A smart switch supported by homey that can handle large Loads (Osram smart+ zigbee=3680W)
  3. A homey :wink:
  • Setup a new zone in Evohome
  1. Enter the evohome setup menu (long press the menu button and confirm)
  2. Select zone configuration
  3. Press + to create a zone and name it (mine is “Zolder”)
  4. Select a type (it does not matter what) I chose zone valve
    ##Update##
    Select zone type: Electric zone! If you choose a different zone type Evohome will also activate your boiler. You do not want that…
    image
  5. Reset the T87 sensor (press left button for 10sec and release),turn the knob and select “Co” and press the left button
  6. Evohome should now confirm the sensor is connected
  7. Press OK, evohome asks to connect the controller, press the assign button on evohome
  8. Since we do not have a controller we ignore the “not received”, just press OK
  9. You now have a new zone in Evohome. Its linked to the sensor. But does not have a controller (we dont care we have homey)
  • Setup homey
  1. If you have an Evohome you will have the app already in homey
  2. Add a new device to homey based on evohome app, the new zone will show
  3. install a smart switch using (osram can be connected via a hue bridge or directly to homey)
  4. Now you can start creating flows using the sensor values and settings of the evohome sensor
    Here my 1st flows

image

image

1 Like

While testing I found that the boiler was triggered to heat up the water. Thats not what you want. So the zone type selected does matter!
I updated the instruction above

PS: this zone type is only available after upgrading to evohome firmware v2.0 (thats on the evohome not on homey)