Homey Community Forum

Fibaro/Z-wave probleem (unsecure include)

Met veel dank aan jullie duidelijke uitleg en motivatie is het me gelukt de aangepaste app te installeren en inmiddels 2 dimmers te excluden en opnieuw includen!
Ik ga alle Fibaro dimmers, switches en double switches van het weekend doen, met de Homey aan een verlengsnoer om overal dichtbij te komen. Vergt denk ik wel even wat tijd om alle settings en flows weer in te stellen.

1 Like

Goed om te lezen dat het gelukt is. Let er bij de overige apparaten op (wat het ook voor een module is) dat je in homey de initiatie start als dimmer2, ik heb namelijk niet alles gepatched, maar ik verwacht dat na de include het apparaat vanzelf goed wordt geïnitieerd als het daadwerkelijke ding, maar dan is die inmiddels al wel insecure.

In de geavanceerde instellingen van je dimmer/switch kan je checken of het gelukt is. Er moet dan een kruisje staan bij beveiligd. Geen vinkje

Je kan hiervoor ook een usb powerbank gebruiken. (Als je die hebt)

1 Like

Net even gecheckt met de Double Switch en dat werkt inderdaad zo! Aanmelden als nieuwe dimmer 2 levert een insecure toegevoegde double switch op.

Ja, kruisjes bij beveiligd

Dat is inderdaad nog wat handiger dan een verlengsnoer, dank voor de tip!

Zojuist alle overige Fibaro modules excluded en opnieuw included, 15 stuks in totaal. Dat lukte in het hele huis zonder de Homey van zijn plaats (die staat in een kast) te halen. Daar stond ik van te kijken, aangezien ik altijd heb begrepen dat die dicht bij moest zijn.

Nu moet ik alle flows aan gaan passen en dus meteen een volgende vraag: wat is nu ze unsecure zijn de meest ideale manier om ze in een flow te schakelen? Met “”->“zet alle lampen uit”? Of toch per module apart, al dan niet met vertraging er tussen?

Ik doe ze nu via “zet alle” uit, en werkt nu prima. Zou daarmee sowieso beginnen is een stuk simpeler, per module met vertaging kan je altijd nog doen

Dat klopt. Er word nu geen beveiligde verbinding opgezet. Als je hem beveiligd include dan word dat op een laag zender vermogen een handshake gedaan zodat er niet “meegeluisterd” kan worden. Vandaar dat je hem dan dichtbij moet houden.

Wat je zelf wilt. Vertraging is niet nodig. Bij mij reageren alle lampen gelijk.
Je kan ook de Groupe app gebruiken

Ik ga dit ook eens proberen, ik heb maar 2 dimmers van Fibaro, de Switches zijn verder allemaal al insecure.
Is dit een Fibaro probleem, ik heb namelijk 2
Aeotec Z-wave Plus Range Extender die ook secure zijn. Geeft dit dan dezelfde problemen?

Waarschijnlijk niet. Mijn vermoeden is dat de fibaro modules de data stroom niet aan kunnen. Bij unsecure word er veel minder data verzonden.

Goeie tip, ga ik onthouden!

Blijkbaar is er een makkelijkere manier om Fibaro devices unsecure te includen middels de originele Fibaro app, namelijk het includen starten als het toevoegen van een Walli Switch. Zelf nog niet geprobeerd overigens, maar de tip komt van gebruiker @Osorkon : Z-Wave Geräte unsecure inkludieren

Ik heb net even gekeken in de broncode, en inderdaad.
De Walli dimmer zou ook moeten werken.

Edit; zat nog even verder de snuffelen maar het lijkt erop dat alle “Walli” apparaten de unsecure regel hebben.
Ook de smart implant bevat de unsecure regel

1 Like

De engelse beschrijving staat hier: Add Z-Wave device non-secure?

Dit topic volgde ik al een tijdje, maar ik zag nogal op tegen het opnieuw koppelen van al mijn devices. Ik heb 30 Fibaro dimmers/schakelaars en een week geleden toch maar de stap genomen om alles unsecure te maken. Uiteindelijk ben ik 4 uur bezig geweest om alles om te zetten van secure naar unsecure inclusief het fixen van alle flows. Het kostte dus even wat tijd, maar het was het waard. Wat een verschil! Echt onvoorstelbaar. Voorheen duurde het uitschakelen van 7 lampen tussen de 10 en 45 seconden en dan waren er uiteindelijk tussen de 5 en 7 lampen uit. Exact dezelfde flow met dezelfde actie schakelt nu binnen een halve seconde alle 7 lampen uit. Altijd. Dit is hoe het moet werken. Voorheen was het eigenlijk sneller om de lampen gewoon met de hand uit te schakelen, maar nu heeft het echt meerwaarde.

In de oude, secure mode, heb ik ook best wat tijd besteed aan workarounds. Ik heb geëxperimenteerd met vertragingen tussen de kaartjes, uitschakelen per zone, de group app etc. Uiteindelijk werkte niets echt goed. Nu, in unsecure mode, maakt het totaal niet uit hoe ik de acties uitvoer. Het werkt gewoon altijd en snel. Eigenlijk zou Athom deze devices gewoon standaard unsecure moeten includen. Dat zou een hoop mensen blij maken denk ik.

Ik kan ook bevestigen dat het toevoegen van een schakelaar waarbij je de “Walli” selecteert de schakelaar ook unsecure toevoegt. Dus uiteindelijk hoef je inderdaad niet eens zelf een andere app te installeren. Je kunt dit gewoon doen met de app uit de store.

9 Likes

nadat ik een vraag in een ander topic gesteld had ivm mijn fibaro roller shutters
kwam ik op dit draadje.
Heb wat verder zitten zoeken maar je kan dus alleen usecure kiezen door de app te wijzigen.
Maar ik wil al mijn devices op unsecure hebben zo had ik het met domoticz en was nooit een probleem.
Ben overigens bij domoticz weggegaan ivm linux problemen op de Pi.

Die heb ik inmiddels op een andere manier opgelost (draaide met berry-boot en een hd).
Heb met de homey tegenslag na tegenslag gefix maar dit gaat me toch iets te ver.
Heb van diverse merken zwave draaien, aeotec, fibaro, qubino en nog een paar, als ik al die apps moet gaan aanpassen daar word ik niet vrolijk van.

Gezien mijn homey nog geen maand in gebruik is zit ik er hard over te denken terug te gaan naar domoticz.

Voor Fibaro hoef je geen andere app te installeren om je apparaat unsecure te maken. Het werkt als volgt:

  • Exclude het apparaat van Z-wave
  • Voeg een nieuw Fibaro apparaat toe, maar kies altijd een Walli apparaat, ongeacht welk apparaat je wilt toevoegen.
  • Omdat Walli standaard unsecure wordt toegevoegd, initieert Homey de pairing unsecure. Het plaatje dat je in de app ziet klopt dan alleen niet.
  • Start pairing op het apparaat dat je wilt toevoegen (waarschijnlijk 3x klikken)
  • Homey paired unsecure met het apparaat en komt er dan achter dat het een ander apparaat is.
  • Homey herkent het juiste type apparaat, maar omdat de pairing unsecure is gestart, wordt het apparaat unsecure toegevoegd.
  • Klaar.

Voor de andere Z-wave apparaten zou ik alleen moeite doen als er ook echt een probleem is. Sommige andere Z-wave apparaten die ik heb, werken prima in secure mode. Ik betwijfel ook of de problemen met Fibaros in secure mode echt door Homey komen. Ik sprak laatst iemand met Home Assistant en Fibaro en die had precies hetzelfde probleem in secure mode. Dus het zou net zo goed aan Fibaro kunnen liggen.

4 Likes

Thnx.
Wilde al bijna de pi weer plaatsen.
Wat ik al melde bij domoticz default unsecure en secure als je dat wilt.

Zijn die icons en type van het apparaat te wijzigen?
De opties daarvan zijn nogal beperkt.
Bij domoticz kon je eigen iconen maken met on/off icons dus over de namen nog maar niet te spreken.
Ander topic eigenlijk ook.

Dat is ook exact mijn vermoeden. Het lijkt erop dat de fibaro modules de data stroom niet aankunnen.

Dat is bij Homey (nog?) niet mogelijk

Nee helaas. Dan moet je de code van de app aanpassen

2 Likes

Als ik developer kijk en dan zwave zie ik vaak dat de rolluiken Unreachable zijn.
Ook zo voor de Universal Binary sensor (allemaal fibaro)
Ook de aeotec multisensor 6 staat dat hier naast online :upside_down_face:

Dat heb ik ook bij veel z-wave. Als je dan ‘test’ doet, dan doet ie het gewoon weer en gaat de melding weg. Het zit niet in de weg voor een goede werking.