Homey Community Forum

Heatit Z-wave app (v2.7.1)

@Jan_Iversen yes, I am awaiting to receive the 4-button version myself, so I can add support for them in the next update.

Assuming you are referring to the Thermostat. I don’t think the device allows for receiving external Z-wave temperature reports… So I would say no.

Good one. Homey energy is looking to the onoffcapability, whereas I needed to use a custom capability thermofloor.onoff. So Homey energy is not noticing a switch.
Based on this feedback, I do anticipate that your are using the ‘old’ Z-wave thermostat?

Yes, I believe it’s the old one. I’ve had it for over a year. Is there any hope of fixing this issue or will only newer version report correctly? I tried “cheating” by copying the state to a virtual device, but it seems that app also needs updating (not an issue for this thread though).

1 Like

Hi, i have heatit Zwater and i use temperature sensors connected to it to control under floor heating. For setpoint i want to use vthermo app which is great. The drawback here id that i dont find a way how to show 4 temp sensor in 4 separate rooms. Someone can give a hint?

Thanks for a great app! :grinning:
Will the z-push button 4 be supported any time soon?

1 Like

I have a heat-it zwave plus termostaat installed in my bathroom with a floor sensor. But the temperture of the floor sensor doesnt update in the homey app. So it keeps saying 17.8 degrees. What do i wrong?

@Jan_Iversen @thomahawk @Benjamin_Hohner With a contribution of @henrikln (greatly appreciated), support for the Z-Push Button 4 device has been added to the Heatit app (v2.4.2).

App is submitted for app store approval by Athom.


I am still having problems with meter readings.

Even after all updates and repairing.

I only get new readings after rebooting homey.
So reading it back does work, havei missed a setting?

Now i get this graph? (every change is a reboot)

Works great, @TedTolboom. Thx.

I do not get any power readings from my z-relay. Have posted an issue on GitHubhttps://github.com/TedTolboom/no.ThermoFloor/issues/32, Is this supposed to be supported, and have anyone else experienced the same?

Same problem with one of my two thermostats.

1 Like

I have got exactly the same problem with z-relay, no info about power consumption…

Somehow an Homey update made it work. Now i get all the data live.

Hi there. Brilliant app! thanks for that.
I have the same question as cortinaman. First i was very surprised that i could read the relay state of Gen.1 of HeatIt Z-wave though your app. I really thought i needed FW 1.92 to do that?! But i tried everything and the “Heating / Cooling turned on/off” is spot on following the red light on the termostat every time. Am i missing something?

So in my head I though that would solve the “constant energy” consumption problem. Is it not possible to report a “fake” on/off state to make it calulate the consumption based on state?

Hey Ted, thanks for great work.

I have a problem with my z-water unit.
I just bougth two 10k ntc sensors and connected them to sensor input 3 and 4, but hey do not give any changes to the temperatures that i can see in “relay 1”
I have standard z-water, no updates.
I asked heatit on messenger and the anwer me this:
You must put assosiations from endpoint 0 (group 1) to gateway with multichannel encapsulation.

Do you know how to fix this?

Best regards


I hope anyone can help me over here! I have (currently) 3 Heat-it TRM2(fx) / TF 056 thermostats, but they keep failing in the network. I followed all the instructions:

  • PTT (take the Homey off mains for 10+ minutes)
  • Let it sit for 40 minutes when booted
  • Reset the thermostats (holding middle + right button for 20 sec)
  • Add the thermostats through the specific TRM2(fx) button in the Heatit Homey app
  • Put the Homey within 20 cm’s of the Thermostat
  • Add the closest thermostat first, and the furthest last
  • After adding all the devices, let the z-wave network rest for 4 hours
  • (In a third or fourth attempt, set Temp report interval and Meter report interval to 3600 and 32000 respectively (as per older posts, which should no longer be necessary, but tried it non-the-less)

After all this, all looks perfectly fine. All the thermostats remain “reachable” in the network and the “RX” from all devices are reasonable. And when I “test” them through the developer pages all seems fine still.

However, from the first time I adjust a temperature, all devices go completly nuts. The “RX” ramp up very fast (from the untouched state of about 50 per day to 10.000 per day) and it’s very hard to set the temp manually, let alone through flows.

log looks like this:

2020-03-03T18:30:01.606Z Node[6]: [COMMAND_CLASS_METER] {“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[33]},“Properties1”:{“Meter Type”:1,“Rate Type”:1,“Scale bit 2”:false,“Meter Type (Parsed)”:{“value”:1,“name”:“Single-E electric meter”},“Rate Type (Parsed)”:{“value”:1,“name”:“Import”}},“Properties2 (Raw)”:{“type”:“Buffer”,“data”:[84]},“Properties2”:{“Size”:4,“Scale bits 10”:2,“Precision”:2},“Meter Value”:{“type”:“Buffer”,“data”:[0,4,212,11]},“Delta Time (Raw)”:{“type”:“Buffer”,“data”:[0,0]},“Delta Time”:0,“Previous Meter Value”:{“type”:“Buffer”,“data”:[0,0,0,0]},“Meter Value (Parsed)”:3164.27,“Previous Meter Value (Parsed)”:0}
2020-03-03T18:30:01.619Z Node[6]: Received application command for COMMAND_CLASS_METER, data: 0x02a12208d000000000
2020-03-03T18:30:01.619Z Node[6]: [COMMAND_CLASS_METER] {“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[161]},“Properties1”:{“Meter Type”:1,“Rate Type”:1,“Scale bit 2”:true,“Meter Type (Parsed)”:{“value”:1,“name”:“Single-E electric meter”},“Rate Type (Parsed)”:{“value”:1,“name”:“Import”}},“Properties2 (Raw)”:{“type”:“Buffer”,“data”:[34]},“Properties2”:{“Size”:2,“Scale bits 10”:0,“Precision”:1},“Meter Value”:{“type”:“Buffer”,“data”:[8,208]},“Delta Time (Raw)”:{“type”:“Buffer”,“data”:[0,0]},“Delta Time”:0,“Previous Meter Value”:{“type”:“Buffer”,“data”:[0,0]},“Meter Value (Parsed)”:225.6,“Previous Meter Value (Parsed)”:0}

Does anyone have any clue what’s happening or how this could be fixxed (or point me to where I can find people who can).

Thanks a million!

Which app version are you using?
Are the thermostats included unsecure (check advanced settings)?
What is the distance between the thermostats and Homey; are there other routing devices (mains powered Z-wave) in between?

Thanks for the super-quick reply!

App version 2.4.2 (Homey version 4.0), thermostats are incuded unsecure (it says “x” at secure).

The first thermostat is about 4 meters from the Homey, the second is about 7 meters and the third is 1 floor up on the exact same spot of the Homey. Those are the only 3 Z-wave devices in the network (currently).

Can you do me a favour and

  1. Send me a log (1-2 hours) of the Z-wave developer tools filtered on Node[x with x the node that is creating the large amount of communication?
  2. Send me a diagnostics report from the app and mention the ID here.
  3. Paste a screenshot of your Node overview with the RX / TX values (after creating the logs)

For this device, which firmware is it running?

Sure thing! I just reset the whole thing again, so I think it’s best to send the logs later tonight or tomorrow morning.

There’s a bunch of firmware versions for the heat-it:

  • Firmware Version: 3
  • Firmware Subversion: 6
  • Firmware Version 1: 3
  • Firmware Subversion 1: 4
  • Firmware ID: 770

I also noticed that all the devices show the following associations:

  • Group 1: 1
  • Group 2: 1.1
  • Group 3: 1.1
  • Group 4: 1

Does that make any sense?