Homey Community Forum

HomeyKit

Can you make a screenshot of the list of capabilities that the device has?

Sure. For your information, this is the app: https://homey.app/nl-nl/app/nl.auping/Auping/

I have a bed with 2 motors (feet and body). There is a 3-motor bed available (but not visible in my dashboard). And motor_bed would be all motors simultaneously

Ah, those are custom capabilities. That’s not something that Homeykit can handle, as they are very specific to one particular app.

And they are not mappable to normal things in HomeKit? :frowning:

It doesn’t look like there is even a remotely similar device type in Homekit. Besides that, I’m reluctant to add support for custom capabilities for basically one specific app.

May this be the right thread to state, that since Homey 4.2.0 Update the Hue-Devices don’t work anymore w/ HomeyKit? :woozy_face:
They’re now just stated as „unknown“ :man_shrugging:

1 Like

Hello together,

is there a reason why Sensative Strip Guards won’t shop up as contact sensor? Apple Home shows them as a switch.

Regards
Andreas

Because it has a “button” capability that prevent Homeykit from detecting the device as a (contact) alarm.

Hello All,

I have a problem with Homeykit and I was hoping someone could help me. It is regarding some Aqara temperature sensors and motion sensors. First I added these devices via the Zigbee plugin for Xiaomi and Aqara. This worked well but I had problems with some sensors refusing etc. Then I found out about deCONZ. I moved al devices to deCONZ and it worked like a charm. But now the next issue appeared. With the Aqara zigbee app temperature sensors would show as temperature sensors in Homekit. But now, with the DeCONZ app, the sensors show up as switches. What could me the issue?

Thanks

If you go to https://developer.athom.com/tools/devices and find the entry for one of those devices, what is the value for the property “Class”, and which capabilities are defined for the device?

Class is sensor.

There are 4 measure capabilities and 2 button ones (button.repair and button.update state) I can set these to false but no luck

I don’t know why it has “button” capabilities, but those are causing the problem. Homeykit has to make a reasonable device mapping from Homey to Homekit, and because the device has “button” capabilities, it is exposed to Homekit as a button (which, in Homekit, cannot have characteristics like temperature, humidity or pressure).

A workaround would be to create a virtual device of type “sensor” with only the temp/hum/pressure capabilities, and use flows to synchronize the virtual and the deCONZ device.

1 Like

Thank you for the explaination. I will contact the developer of deCONZ to ask why these are capabilities in the first place.

Does it support Homey homeyVersion “5.0.0-rc.34”?
When installed the code 200 20 200 does not work.

It should: it’s an SDKv2 app that doesn’t use Zigbee, and those should function without changes on the new firmware. I haven’t tried myself because I’m not inclined to install experimental firmware.

That can have any number of reasons, including a lot of reasons outside the control of Homeykit (for instance using VLAN’s or separate subnets for IoT devices, which may cause problems with multicast). Sometimes it helps switching WiFi off/on on your phone.

1 Like

WiFi off/on did the trick :wink: