How can I easily see the mesh network for Z-Wave and Zigbee to spot weak/broken connections?


#1

How can I easily see the mesh network for Z-Wave and Zigbee to spot weak/broken connections?

I try to extend the networks in my fairly large house, but I have no control on where the signal gets weak or ustable.

Is there a tool I can run to spesifically see how good the signal is on the nodes/network or do I just need to put devices around the house or buy enough of them to make the mesh work properly all over the house?


#2

You can see details regarding your zwave and zigbee networks with in your tools.

https://developer.athom.com/tools/zwave

https://developer.athom.com/tools/zigbee

From there you can see all the information you need to figure out what you want.

NodeID Device Route Tx Queued Tx Sent Tx Error Rx


#3

Thanks, but I dont see any devices listed. I only get a “response_timeout” message in the bottom of the web page now and then.

On the Zigbee page, I see a list of devices though, but how do I see how good the connection/signal is?


#4

It takes a moment to load.


#5

It never shows up. I only get a “response_timeout” message in the bottom of the web page after 30000 ms. Is there a point to contact support about it?


#6

You must log in to your Homey and therefore be on the same network.


#7

I already am. I see the ZigBee devices just fine and also other Z-Wave information. Just not the Z-Wave device list. Support is checking out the problem.


#8

Still, if anyone know: How exactly can I easily see the mesh network for Z-Wave and Zigbee to spot weak/broken connections? I’m new to Homey and smart devices. Any help is appreciated. Thanks!


#9

the map of z-wave devices isn’t currently working. it was mentioned in a different thread yesterday. It is also likely that in requesting the map/topology that the z-wave will have crashed and devices wont work until you pull the plug on homey and restart it.


#10

I believe that the ‘map’ was actually removed, on purpose by emile.

I’m sorry I don’t know how to help you further other then showing you where the table is which easily shows each device, along with its mesh network and exactly the connections, what has been sent, received and error. ie. weak/broken spots.

Further more it allows you to send node information, raw information and log.

Hopefully once support have fixed your issue you will have everything you need.


#11

The ‘route’ column displays after some waiting/reloading of the page the route all zigbee devices create. Zigbee devices with type ‘router’ can act as a mesh node, while other ‘end device’ type zigbee nodes can only make connections.


#12

Thanks for the info, hwin! How can I know if a product is routable? Is it a spesific word that is on the box or on the spesifications for the device?

For instance, is the Innr ZigBee mini plug routable? According to Homey, all my 9 ZigBee lamps and plugs go directly from Homey which seems unlikely as one plug is at least 30 meters away and one level below through a thick glass door, concrete floor and several log walls.


#13

have a look at the column ‘type’:
afbeelding

on the zigbee page:
https://developer.athom.com/tools/zigbee


#14

Ah, all right. Thanks again! Seems like all Innr plugs and Ikea bulbs are routers. I guess most devices are then. However, somehow the developer.athom tool isn’t working or it just doesnt want to route in my house. This is how it looks like at my place:

No routing whatsoever. How can I fix that as the plugs with lights furthest away sometimes respons after 5-6 seconds and sometimes after half a second?


#15

Looking at my overview it seems that the routers don’t form any mesh network at all. Its just the EndDevices that route their data via a Router type zigbee device:

So it seems that homey is not very efficient at forming a mesh network with these zigbee devices. No clue how to influence this. Anybody else any ideas?


#16

U have problems with ur devices (besidesthe E14 bulb) like they are out of reach or something?


#17

Yes, they are unstable. Sometimes they don’t work. Wait 10 minutes and you get a respons within 3-5 seconds. Try 30 minutes later and 0,2 seconds respons. Try again 10 minutes later, and the devices is unresponsive.


#18

Well, first try to get ur E14 bulb up and running again. Like power down the bulb and put the power back on. Takes a while to get back online in the developer tools.


#19

I think you are confusing my picture (which you replied to) with Master Aeons problems?

I have no specific issues with zigbee or any e14 bulb. Other than the complete zigbee network crashing which needs a homey reboot to fix.


#20

Hmm. According ur pic the E14 bulb is not connected to Homey. But maybe am confused yes.