Homey Community Forum

Http request card app is not responding anymore after update to homey2

#1

I updated last week my homey to version 2 but i can’t get http request card to work anymore.

When i call the url:
https://xxxxxxxxxxxxxxxxhomey.athom.com/api/app/com.internet/rob/gaatweg
Where xxxxxxxxxxxxxxxx = my homey ID
Before the update it worked and the flow was triggered.
When i use:
http://ip.homey.local/api/app/com.internet/rob/gaatweg
Then it works

But when i open the url using https and my ID i get a page with:
Sorry, this Homey is not connected…
Automatically trying to reconnect…

When i go into settings -> general -> Athom cloud ID and use that id (xxxxxx) then it is exact the same as in the link with https, so the ID is not changed.

Anyone an idea what i am doming wrong or why it is not nor working anymore?

I disabled api authentification.

Simple HTTP Connector For Flows
#2

Can u try https://xxxxxxxxxxxxxxxx.connect.athom.com/api/app/com.internet/rob/gaatweg

#3

Yep that works…
Hmmm, so homey has to be changed into connect?!
Strange that this not listed somewhere, but thx for the info!

#4

When using it local u can also do just
http://IP-ADRESS-OF-UR-HOMEY/api/app/com.internet/rob/gaatweg

#5

yes i know, that stil worked, but it suddenly stopped working when i used remote connect on my id using https://xxxxxxx
Now it seems that since homey update from 1.5 to 2.0 homey.athom.com is changed into connect.homey.com

I changed it in tasker on my phone and now it works again.

Thx

1 Like