Homey Community Forum

Is there anyway to see which flows are still using deleted variables?

When deleting a device, flows get a triangle with exclamation mark in it indicating that they are still using a non-existing device and won’t work anymore.
However when deleting a variable, flows do not get any indication that it is using a non-existing variable, instead the flow card just gets an empty field.
So when deleting a variable, it seems that there is no other way then just opening all the flows and checking the flow cards for empty fields.

Or does somebody else have a smart idea how to check, whether flows are using non-existing variables?

The most simple way i use is the naming of the variables. It’s an indication what it’s used for and therefore easier to trace where it is likely used.
But i guess if you have many of them that would be more difficult.

I have approx 90 variables of all kind of types, not sure if that’s a lot of not. I do give them self explaining names, but that’s not enough to determine all the exact flows (more than 100) they are used in.
Thanks anyway for your suggestion though :+1:

1 Like

Try searching for “broken”, not sure if that works for variables.

Not a real solution to your problem, but it does help preventing it.
What I did is:
1.I installed the flow viewer (thanks to @DaneedeKruyff) .
2. Your browser will now allow you to print a pdf of all your flows
3. The pdf is searchable, so when you remove a variable, search for it and remove it too

1 Like

Thanks, that might help indeed.

I tried in a logic flow card when adding a variable and then searched for “broken”. No results.
Could be because there are none anymore, but could also be that your idea does not work.
But thanks anyway