Homey Community Forum

MQTT Hub/Gateway


#266

Did you get this to work?
Exact same problem here…


#267

Maybe someone knows what this java.lang.NullPointerExeption error means?


#268

You need to connect to a broker first (within openhab)


#269

I have connected to Broker, running on Homey.


#270

Sorry, I don’t know what’s going wrong (based on your provided info). Did you try the openhab fora?


#271

Trying to figure out whats going on…I still don’t know the reason, but at least I’m able to reproduce the issue now! I Added another MQTT Homie device as a test. This one is displayed offline while another is correctly displaying the online pending message. It’s the same configuration, strange…


#272

@Bananfluen Found it!

I forgot to select a bridge (the homey MQTT broker) when creating the MQTT Homie device.


#273

FYI: The homie2 branch contains an updated version:

  • fixed a bug for initial settings (i.e. undefined bug)
  • zone & device class will be normalized
  • added some warning messages

#274

I think really there should be an alternative available in the ‘Communication Protocol’ drop down that supports things like the inclusion of the zone and class additions in the topic hierarchy. Called ‘Hub’, ‘MQTT’, ‘Custom’, ‘Default’ or something. If the homie3 protocol is selected then ‘class’ and ‘zone’ topic inclusion should not be selectable, or anything else that breaks the spec.

I also see no problem with the original normalisation of the class and zone entries in the topic levels as capitals are not an issue outside of the restrictions of the homie3 protocol.


#275

Adding a ‘custom’ protocol is a great suggestion.
When the Homie protocol is selected, most of the additional settings will be locked, selecting ‘custom’ will unlock those.

Also making the topic normalization optional is added to the list.


#276

Harrie - are you on top of an issue where the ‘set’ topics don’t work - not updating the state within Homey? There’s quite a lot of them across several devices, or shall I create an issue on GitHub?


#277

Nope, I did not came across one. Could you provide me the details?


#278

Will do here’s some off the cuff but I’ll research better and update tomorrow.

Some are boolean within onoff and some numeric in say thermostats where set target-temperature is ignored, custom-thermostat-mode too. There’s one or two where no state is reported for the device like buttons and in those set is also ignored.

But aside from a couple of devices it is working really well for a lot of people, me included


#279

Now both online! :blush:

Can’t see any devices…


#280

online

I have it online in OpenHAB and see channels when I click on the “Homie MQTT device”

so next step is to add it in Items and Items can be created in f.i. the Dashboard of OpenHAB? if so how to see the Items?


#281

@Sat2All You can click in the blue circle to create a ‘thing’ for the channel. Next you can connect these ‘things’ to controls on the dashboard.


#282

@xAPPO Custom protocol is implemented


#283

@HarriedeGroot, I also have some ‘set’ problems.
When i hit the button ‘Staande lamp’ i can see in the Explorer that the field set is created with the value true. However the field onoff isnt changing.


#284

@Marcel_Wolf What type of device is ‘staande-lamp’?


#285

It is a Ikea bulb