Homey Community Forum

Onkyo app not working correctly

Used flows to control my Pioneer VSX-s520D. Worked fine, but now some commands dont’n work anymore. In the test option of a flow a “running wheel” keep turning. These flow used to run fine. The only command that seem to work is the “Turn ON”-command. Swith input to “DAB” en choose preset channel, don’t work anymore. I’ve deleted and reinstalled the app… but that doesn’t solve the problem.

WIch version Homey and Onkyo app your running on?

Because if your running the Onkyo BETA app , there is no more support for Pioneer VSX receiver.

Thanks for your quick reply. Homey version 3.0.0.
Onkyo-app version 2.04 (dont know of this is the beta-version).

Would-be very annoying of Pioneer wouldnt be working anymore.

Can I Go back to an older version?

Version 2.0.4 is the latest version where the Pioneer Receiver is support.

The Beta release is on version 2.1.x, but these are rewritten by myself and as told before no Pioneer Receiver support any more in this versions

You can’t go back to older version unfortunately

There is nothing changed in V2.0.4 that should stop the correct working of any flows.
But perhaps something in the SDK from homey3.0 is changed and therfore the code is not working correctly anymore,

I can’t test this don;t own a pioneer receiver(i have a Onlyo)

What you could try if possible is run the app in CLI mode then we can see the debug logs.
You can pull (or download) the 2.0.4 version from https://github.com/mickelluiten/com.onkyo
You need the master branch.
Remove the app from Homey and run the downloaded in CLI mode.
Maybe we can see something in the debug logs?

Also Homey 3.1.0 is out please upgrade to that version.