Homey Community Forum

Qubino ZMNHXD1 3-phase smart meter

I sent an email today to support@athom.com to ask if they can add support for it. Maybe if you will do the same support will be added sooner

I emailed Athom about a month ago & still no solution. Athom can’t reproduce the problem & Qubino can’t find the problem.

Athom are asking for everyone with the issue to report it.

Meanwhile is there method to examine the data communication from the meter more directly to try & find whats going on? I imagine a Z wave USB device might be required.

Leo,
Athom asked me to fill in this form for support.

in developer - tools - zwave is apossibility to log the z-wave communication, you can filter on the device-id

I’ve tried that & indeed sent the output to Athom but no result…

I’ve contacted the manufacturers (Qubino) & they say that they will send on a z wave dongle & application to capture from my device directly (bypassing Homey), hopefully it will uncover the issue.

I’ll report more when I have news…

1 Like

Gunnar,

Can you please tell me how to install the driver on Homey? I got firmware H1S1P2 and would like to try it.

Update

Hello all,
I’ve an update from my last post. Some good news & some bad…

Good news
The good news is that the issue appears to have been identified & can be fixed. I’ve been in contact with someone from R&D in Qubino & last week we managed to capture the problem on my module. The issue appears to be with the encrypted communication on the module & it can be fixed with a over the air (OTA) firmware flash. I’ve been running new firmware on my module for the last 4 days or so & so far it’s working fine.

Bad news
This leads me onto the bad news, to flash the module it required a USB Z wave controller to upload the new firmware file from a computer/ laptop, obviously not available to most users out there. The individual in Qubino will be passing the findings on to Athom & reports that they (Athom) are working on including an OTA feature in Homey, but no timescale or confirmation of this.

Sorry it’s not better news.

Regards,

Leo

3 Likes

Leo,

Good that you find a solution! I am really happy with it.

I don’t know if you are dutch. But maybe it is possible that if you are dutch that I visit you and that you can update my meter?

Sorry, but over in Ireland, bit of a journey for you!

I used one of these:

https://uk.pi-supply.com/products/z-wave-bridge-usb-controller-for-home-automation

Regards,

Hmm to bad! Have been in Ireland twice last year

Leo,

Can you send me the software and instructions to update the meter?

Sorry for the late reply.

I unfortunately deleted the firmware supplied to me by Qubino but I cant see that they’d have much issue supplying it.

The software to run the Z wave controller im fairly sure comes with the device or is available from the manufacturer.

Leo,

Many thanks! I contacted Qubino and they are going to send me the firmware. The only question they got is do i need the Kia or Bicom?

Sorry but not sure what that means! I was in contact with one of the support personnel who simply sent me a file.

Regards,

Leo,

I tried to do the update and installed the meter but values still dont update. How can i check the current firmware?

Hello, I tried the samen with a QUBINO_SmartMeter3PhaseS2_500_EU_14122018_1406_ZMNHXD1H1S1P2_V1.otz file from Qubino support but also still get no updates from the device.
By the way, I pushed the update with a Razberry.

Erwin,
Can you send me the software and instructions to update the meter?
Regards

There is a way to do this using the z wave dongle & ‘joining’ the meter to the USB controller. Qubino showed be able to help you with this.

Regards,

Here’s the process to update the meter that I got from Qubino:

To do an OTA (over-the-air) update:

1.) Include the device on the USB Z wave controller network, if it is not included yet

2.) Go to the “Firmware update” section, browse to the file and press the “Update” button two times.

3.) Perform a factory reset of the device by holding the service button for at least 6 seconds, the device will also send a DEVICE_RESET_LOCALLY packet, indicating, that it was reset.

4.) Include the device into Homey and, hopefully, the issue shouldn’t appear again.

Regards.

Apologies but looks like only images can be sent on this forum.