Homey Community Forum

Qubino ZMNHXD1 3-phase smart meter

Step 1:
Install Node.js

Step 2:
Download app Qubino beta version

Step 3:
Modify file « driver.compose.json » on drivers/ZMNHXD folder
With a text app, replace the text :

},
“zwave”: {
“manufacturerId”: 345,
“productTypeId”: 7,
“productId”: 84,
“associationGroups”: [
1
],
“learnmode”: {

by

},
“zwave”: {
“manufacturerId”: 345,
“productTypeId”: 7,
“productId”: 84,
“associationGroups”: [
1
],
“includeSecure”: false,
“learnmode”: {

Save the file

Step 4:
Install the homey app
Opening Node.js
Install homey application on node.js, tapping :
npm install homey

Or
npm install -g homey if you have admin access

Step 5:
Tape homey login
Follow the link in your browser

Step 6:
Access of your folder where you download qubino app
Example : cd users/Manuel/qubinoapp

Step 7:
Install your qubino app :
homey app install

Step 8:
Associate 3phase smart meter following steps in your homey phone app.
It works better if homey is near of the smart meter when you associate for the first time.

1 Like

Hello, I do not fully understand the procedure from step 4 … Could anyone describe the procedure from there in a little more detail?

Thank you in advance to all.

[HOW TO] CLI install method - #5 by Ruud maybe that will help :wink:

1 Like

Manuel,

Does the values auto update? Or only on restart of the app?

HarmJ,
Yes it auto updates, I don’t have to restart the app.

Which firmware version are you using with you 3 phase smart meter?

I’ve firmware version “1406” with date 2018-12-14.

I get values for a few hours, after that all values stops updating. I’ve doubled checked that my meters are included unsecure.

I have these informations in homey (in French):

Thanks,

Can you reset the power meters? I get timeout error when trying to.

Do you know which version you’ve of the 3 Phase Smart Meter?

ZMNHXD1 H1S1P1
ZMNHXD1 H1S1P2
ZMNHXD4 H1S1P1

Hi,
I can reset the powermeter only on the powermeter itself, not with homey.
Where do you find the information of version ?

How do you do to reset the meter itself? I’ve searched for instructions in the manual, but I couldn’t find any.

I’ve contacted the Qubino support (talked to Igor, he is very nice and helpful) and he sent me the latest firmware for my meters (ZMNHXD1 H1S1P2).

So, I’ve just updated to version 50.06 (dated 2021-01-07). I still can’t reset my meters with the reset button in Homey, but hopefully values keep on updating. I will get back after testing the new firmware.

With the circle button, pushing the button until you see the screen flashing :

Then you have to enter in the SET menu, with the same method, and then in the Rst Cnt menu.


Thank you! :slight_smile:

So, even though it feels good to know that I’ve the latest firmware on my Smart Meters, it didn’t solve the issue. I get updated values for a couple of hours, then it stops. Workaround is to restart the Qubino-app.

Speaking of the Qubino-app, the ZMNHXD1-branch is quite old and outdated. Maybe it would be worth the effort of trying to make a new mod of the master-branch?

@Manuel_Martin I’m using default values of all parameters, have you changed any to get it working?

Clearly, if some developer or Homey team could work on the app to solve it, It will better, but I’ve tried to copy paste ZMNHXD1 folder into the updated app, and it doesn’t work.

Do you have other qubino devices connected of your homey, because I don’t have, and maybe it’s a part of the problem ?

I think I’ve changed the reporting interval, but I don’t remember clearly.
Please find my parameter values :
IR relay auto-off threshold (W) = 0
External relay auto-off threshold (W) = 0
Delay before power on relay (s) = 30

Inputs
Switch type input 1 = Disabled
Enable external IR relays = Disabled
Enable external relays = Disabled

Power reporting
Power report on power change (%) = 1
Reporting interval - Power, Apparent Power, Reactive Power (s) = 30
Reporting interval - Voltage, Amperes, Power Factor, Total Reactive Power (s) = 30

Associations
Groupe 1 = 1.1

Paramètres de configuration raw
Valeur =

Thanks!

I’ve three Smart Meters, no other Qubino devices. Maybe it’s all combined traffic that’s causing the problem?

Do you also have the ZMNHXD1 H1S1P2, or do you have the newer version ZMNHXD4 H1S1P1?

I found that in internet, it seems there is different versions of z-wave frequencies :


Mine is ZMNHXD1 H1S1P2
Where did you find firmware version ? I can’t find this information

D4 is a different frequency, D1 is the normal EU version.

Oh, thanks for clarifying @JPe4619. :slight_smile:

So, there’s really only two versions, H1S1P1 and H1S1P2, where the latter can be updated OTA.

1 Like

I’ve used a PC with a Z-Wave dongle and the “Z-Wave PC Controller” software to perform firmware updates. It can also get the current firmware version of the meter.

1 Like

Well, for the first time, my 3 phase meter is not sending data :grimacing: