Homey Community Forum

Sending multiple Zwave commands at once

I have 5 FIBaro dimmer 2 hooked up to switches. If I press 5 switches together all lights go off together as you’d expect

However, if I send a command via Homey then basically they all go off at varying intervals taking 20seconds or so to actually complete

If I go via Alexa it’s even worse (grouped by Alexa) as sometimes commands get lost, or delayed further

How can I improve this?

Hmm I’m no expert on the subject, but I don’t think there’s much you can do.
When you press the physical switch, the signal will go to the switch instant without delay. The dimmer vil shut down the lights and then send out the signal to Homey with a delay.

When you shut off the lights via Homey, Homey will send out one command at the time, the dimmer will receive this command and turn on the lights. The dimmer then reports back to Homey that the command was succesful. You will then have some delay due to all the wireless communication going back and forth. Z-wave for ex is only using 8-900mhz and that’s not fast enough to get no delay…

I would program the switching commands delayed by 1 second, which protects against overloading the Z-Wave network.

I don’t mind a delay (even 5 seconds), but what I would like is for all the lights ideally to go off ‘together’

@fantross will try your option - if it works I can work around Alexa. It’s still not ideal however as it’s not ‘all on’ it’s ‘all on one by one’!

If you press the buttons manually, you don’t need to send a command to Homey, it will be done in the background bit by bit. The Fibaro Dimmer 2 also works without a connection to Homey.

Yeah, i get this - i’m not expecting it to be ‘instant’, a small delay is fine. 20 seconds with random turn off order and sometimes failing isn’t good tho - I’m just looking for ways to improve this.
With my wifi bulbs (Yeelight), if I turn off multiple bulbs they go off together (near enough)

I have 22 of those dimmers (mainly to have my lights still working work when Homey does not). To overcome the issue I use a 1 second delay between each action in the flows and do not use the general “switch off all lamps” card. (e.g. lamp 1, lamp 2 with 1 second delay, lamp 3 with 2 second delay, etc). Reasonably stable for a while now

Triggering all at once results in lights staying on (or off) most of the time like you see too.
Still have the issue that Homey does not get the feedback from the dimmer in case it is switched manually, so my next step is to re-include the dimmers insecure by changing the app, however that still requires me to dive into CLI first…

1 Like

The group app will attempt to retry if toggling the device fails.

There was a git hub feature to automatically add a delay floating around as well.

But generally you will still find the same delay exists, the more items you add to the group - the bigger the delay.

1 Like

What means CLI?

Command Line Interface, best to search a bit: [HOW TO] CLI install method

1 Like