Homey Community Forum

Ubiquiti unifi en docker

Ik heb de unifi controller op een ds918+ draaien via docker en krijg hem niet verbonden.

Ik loop telkens van verbonden naar niet verbonden

Foutmelding: Error while fetching ap list
Statuscodeeror 401

Iemand tips

en als je naar die unifi controller via de website gaat, dan gaat het gewoon goed verwacht ik? Foutmelding geeft volgens mij aan dat hij wel verbinding maakt maar de AP lijst niet kan ontvangen. Klinkt vreemd. Welke versie docker heb je?
Ik draai ook de docker van de controller 5.12.66 meen ik. Host heb ik m’n ip van de nas, poort is 8443 en dan username password, site heb ik default.

401 is een authorization error.

Versie docker is 18.09.0-0506
Ik heb een gekoppeld pad in een unifi map met pad: /var/lib/unifi
Ik kan de controller inderdaad gewoon openen via de browser en er worden ook zaken weggeschreven in de map op de nas

Site: 192.168.1.50
Poort 8443
User en pw waar ik op de unifi controller via pc op inlog
Site: Default (staat in de controller ook met hoofdletter

192.168.1.50:8443 kan ik inloggen en zie ik mijn punten en alles werkt daar

Dat is de tutorial die ik heb gevolgd

Mijn login en pw kloppen, extra gecontroleerd, is het misschien iets met een machtiging?

Heb je het goede site id? De app op Homey geeft de id’s onderaan de instellingen. Alternatief vind je deze in de URL als je in je browser naar de controller gaat. Of een keer default invullen en dan opnieuw proberen.

Site id is Default met hoofdletter in de instellingen van unifi, dit heb ik zo overgenomen
Via mijn tablet waar homey op staat heb ik toegang tot de controller en via de app van unifi zelf op mijn tablet werkt ook alles, enkel in homey krijg ik het niet aan de praat

TFA aanstaan? dit was bij mij het probleem waardoor ik een 401 error kreeg :slight_smile:

Waar moet ik dat aanzetten?

Ik bedoelde heb je 2 factor authorization aanstaan voor je ubiqity account? Ik draai zelf niet in een docker maar gewoon met cloudkey maar door TFA werkte homey app niet met exact dezelfde 401 melding. TFA uitgezet en het werkte meteen.

Net getest met en zonder
Met tfa verbind hij helemaal niet, zonder tfa korte verbinding en de loop verbonden niet verbonden…

In ieder geval bedankt voor de tip, veel verder geraak ik niet :cry:

Ik ga hem eens in Java draaien, kijken als hij dan werkt…