Homey Community Forum

Xiaomi Mi Roborock S50 vacuum cleaner token

The token is correct because I can use the RoboRock Control Centre (windows app)

But when using the homey app the error: app device.getstate is not a function

No one? too bad bought this roborock because I could integrate with homey. The token is correct but I think the APP needs an update? token is correct because I can controll the unit with the windows application.

Who can confirm that they have it working with firmware: Homey 5.0.0-rc.34 and S5 Max 01.10.26

Have you tried the MiHomey app?

No not yet. CLI install?

Did the CLI install of the MiHomey app. No luck yet… When adding nothing happens. strange thing is that the widows application again works flawlessly with the IP and Token.

It bugs me that I cannot figure this out

Homey handels the communication different than Node Red or the available windows RoboRock Control Centre application. Any other explanation?

Had some problems with connecting to my roborock s5 max after getting the token - what I did wrong was that I did not install the custom Homey app that is required for newer roborock devices.

After I installed the custom homey app, everything worked well! I followed this tutorial: https://homey.guide/fa-xiaomi-roborock-s5-max-s6-i-homey/ (sorry its in danish)

6 Likes

Tried too get the token, fine.
In homey i have this fault :handshake timeout"
Any idea?

Try installing the custom homey app I mentioned in the link above :slight_smile:

When you add it this way, Is it possible to pin & go or room clean?

Unfortunately not, I have not found a way to to that with that app. If you want to support it I guess you have to create a custom app yourself using the miio tool available on GitHub.

I thought maybe this is the one with room cleaning etc. I think this app is the same as the one on GitHub.
Unfortunately I’m not good with writing code. So I can nog build it myself.

Got the token. Installed the custom app trough CLI and have added the roborock s5 max in Homey so far Hoerayyy!!! On my phone i run the latest Mi Home app from the google store and i can also controll my S5 Max from there. Now i want to have the S5 max also connected to Google home. I tried the three different google connections. when i use “Roborock” i can connect i see the S5 max in google home the S5 Max is available as a device. When i try to controll it i see that it is not responding and google home keeps trying to connect. When i remove the device and try " Mi Roborock" i have the same result. When i try the “Mi Home” there is no device connected. My goal is to control the S5 max by voice (for the wife) and control the S5 max trought flows when we are not at home

Perfect, Thanks for sharing. After al this time i got my Roborock S5 Max connected to Homey. Will be doing some flow testing tomorrow.