Homey Community Forum

Z-wave devices does not work in flows

Hi,

I have noticed that two of my Z-wave devices (one Fibaro switch 2 and one Telldus wall plug) have start to fail, in this case not turning their lights bulbs off. It seems that all this started after the update to V2.1.2. Before the update all flows was working flawless . Controlling the lamps through the devices in Homey works, but it seems that when they are in a flow the problem starts. Strange thing is that the devices turn the lamps on without any problems but always fail to turn the lamps off when in a flow.

Have anyone experienced the same?

Regards/ Lasse

Welcome Lasse. To be able to determine what could be wrong, a print screen of your flows might be very handy…

Hi
Please notice that all flows have been working before the update.

You could try to make small and different delay’s in the OFF commands

1 Like

I have tried that without success.
I think the problem is when “one flow starts another flow and that flow has Z-wave devices in it”.

I have made duplicates on the first flow, removed the flows in “Then” and replaced them with the Z-wave devices. We will see tomorrow morning :blush:

Thanks for the help!

Hi Lasse!

Please allow me one (stupid?) question:
Why are you doing that complicated construction of one flow starting multiple others? Why don‘t you put the ‚off‘ commands directly into the first flow?

Best

Manfred

Hi,

Good question :blush: My thoughts in the beginning was to create “base flows”, for eg. “Turn garden light on” and “Turn garden lights off” and then use them in other flows. For instance, I use “Turn garden light on” at sunset and another 3 hours, but I also use the same “base flow” flow and turn the garden lights on when there is a movement in the driveway. It will also be less flows to update if I, for some reason, want to add a garden light or change the name of a included device.

Regards/ Lasse

Hi,

I have now tried my idea to control the devices directly in the first flow without any success. Actually, this morning the devices was marked as “off”, but the lamps where still on. I will try to put a delay for a few seconds in the off command and see if that helps.

Regards/ Lasse

Hi, how far is the zwave light module from Homey? How many zwave modules do you have?

Right now Homey are less than 15m from devices. I have four Z-wave, all + certified.

Problem solved :slight_smile:
It was not Homey nor the wall plugs causing my problem. It was the flow that was turning my lamp ON - not the one turning it OFF as I thought. My lamp was supposed to turn ON at sunset and turn OFF at 9:30 pm. Due to the fact that sunset now has getting close to 9:30 pm, the delay time for turning the lamp ON happened after 9:30 pm. Have to think of another way of conrtroling the lamp :slight_smile:
Thank you all for your concern.
/Lasse