Homey Community Forum

Z-Wave Raw Data Format Dev Postal

I’ve had a homey for quite a while, just getting round to doing some dev for a SE813 Everspring Voice Siren.

The docs list the spec for getting it to play sounds, but I’m struggling to use the dev portal to send the command - Just for dev debugging, so I can work out what’s what and then build a driver.

The Manual has:
Sound Play Back: Parameter Number = 3, Size = 1, Range = 0-99.

On the homey iOS app I have a basic z-wave device setup, and if I go to the advanced settings and set the config in there as like 3,1,7 -> it plays the voice file. cool. So I know it’s working. How do I send the same settings through the send raw data on the dev portal?

the help test says node, param1,param2,paramn

But I can’t figure out the format. Any help would be appreciated!

I’ve looked at some other posts for similar and saw 4,0x70,0x04,0x3,0x1,0x7 but it doesn’t work, (the 4 being the node id).

Same thing here… I am trying to send raw data to a z-wave node (Qubino RGBW dimmer) via the developer portal, but it doesn’t seem to work. Even after excluding/including the device.
I want to set node 30 parameter 14 to 1, so I sent 30,14,1 as raw data, which is accepted:

2019-09-05T11:46:55.041Z Command[1077] start: sendData
2019-09-05T11:46:55.043Z ProcessSendData[1042]: To node: 30 with data: 0x0e01 and txOptions: AUTO_ROUTE,ACK,EXPLORE
2019-09-05T11:46:55.069Z Command[1077] end: sendData

I am using Homey Pro version 2.5.2, and the Qubino app v2.0.10 - 29.01.19. The switch is the Qubino RGBW dimmer ZMNHWD1

Any help is appreciated!

Raw parameters (or better said “expert parameters”) are send in the device’s advanced settings, not from the developer tools, that is fully raw z-wave command (even more expert)

Unfortunately, the parameter that I want to set on this device cannot be set in the advanced settings. Athom suggested that I use the raw parameter setting, however they do not support this and therefore suggested I put forward this question in the community.

But again unfortunately, this seems to be a tough one to answer, as @MKB also already found out.
The developer tools, z-wave section, tools card has a placeholder text “destNodeId, param1,param2,paramN”. But when I enter 30,14,1 it clearly does not work, although it should be the right parameters.

So, the big question remains… How to format the raw command??

You need much more “parameters” when sending an configuration parameter, raw data is for all possible z-wave commands, not just parameters (like the expert parameters) which is only 1 of the many possible command classes.

Dest Node ID, Command Class, Command Class Function, Value(s).

so you should also add the Command Class for CONFIGURATION Command class (112) and the SET Function (4) in your line:

30,112,4,14,1,1

30: Destination Node ID
112: CONFIGURATION Command Class
4: CONFIGURATION SET Function
14: Parameter ID
1: Parameter Size
1: Parameter Value

But keep in mind, this only works for unsecure devices, secure devices need extra handshake (securing) data that you can’t do manually, you aren’t fast enough for that.

1 Like

Thanks a lot! That was what I needed.
My Qubino still doesn’t do what I want it do do, but I think I have to take that up with Qubino support.

Is there any reference where I can find the format of these commands?

Sure, you only have to read/search through 1000+ pages of information, but if you are interested, there are 2 links on the developer pages: z-wave under the header “Command Class Reference”

1 Like

I think I’ll take your second suggestion. :wink: Once again, thanks!