Homey Community Forum

[APP][Pro] Tesla Smart Charger

“Add current location to geofence” where is that function located? I am not able to find it.

You must create a flow with that function and trigger it if the car is in that location

Yes, it is a bit cumbersome, but you only store the data once.

You can determine the location under “AND”. “and location is…”

These flows are unnecessary because the app checks the status of the car while it is active, and that is it while driving, every minute, as @balmli has just explained to me.

You can set the “Data fetch interval” once and then leave it like this.

If I set the data fetch interval to a small value, the car will be woken up very often and as a result the battery will get drained rapidly. This is the reason I am trying to create flows that will change the “fetch interval” value.

This is what I have done:


I think this will work. I will give you a feedback later tonight.

The idea is simply to trigger a given flow when the car leaves home or comes back home…

I don’t think you understood it.
When the car is in motion, the data is compared every minute anyway.
You don’t need to change that.

I switched off “fetch” because I only need data from the car when it drives.

Ok. But this is not working for me… Check this post: [APP] Tesla Smart Charger - #171 by FEY and the subsequent thread you will see what I am talking about.

Of course, if you have a solution for this issue it will be great.

If your car is at home, it is dialed into your WiFi, if so you also have other options?

Again, my issue is that when I am getting home (Home Geofence), the flow is not firing… I need it to fire when i enter my home geofence and not when I get home and park the car…

Here you say that it doesn’t work when you leave the house?

After creating the flows controlling the “Data Fetch Parameter” (when moving set to 1 min) and when stopped set to 300 and verifying that they are working by sending notifications, the car is seldomly starting the the flows triggered by Vehicule came home or Vehicule left home.

For instance, yesterday it worked twice out of the four time the vehicule left and came back home. This morning, it did not work at all. By that I mean that the flows did not get triggered.

@balmli do you have any suggestion?

I added my Tesla Model Y to Homey using this app, but I see that the device is missing a icon. I could of course choose a different icon in ‘Edit device’, but none of them are suitable for a car. Could you developer add a default icon for Tesla car devices?

Here’s v. 1.3.3 with icon for Model Y.

You’ll have to re-add the car to get the icon.

Please test, and report back.

1 Like

Updated and tested to be working fine. Thank you for quick fix.

1 Like

@balmli is there any Plan to integrate the powerwall into the app

This would be great

Maybe this app ?

1 Like

Yes, thanks

Installed App, but log in after Setting ip is Not possible with error: could Not find pairsession

Edit: password Problem, but solved

Looks like Tesla has switched to reCAPTCHA, which is not supported by the app. So logging in does not work.

I’m. not sure if / when this can be fixed.

Darned, indeed, any attempt to connect fails on the captcha. Really hope this is solved soon!