Homey Community Forum

IOS Presence app (locative)

An IOS presence app working with webhooks.

Found an IOS presence app in the app-store working with webhooks or GET requests. So you can use the build-in logic cards in Homey for receiving a webhook or the Better Logic app for receiving a GET request.

Go with your IOS device to this link and download the app.

Setting a geofence

When you first downloaded the app the geofences will be empty. Click the + sign on the top right to add a geofence.

Setting the url

When the geofence is added you can also add the GET url for the webhook at the “Trigger on Arrival”. The url for the webhook will look like this:

https://Homey-cloud-ID.connect.athom.com/api/manager/logic/webhook/event?tag=tag

In this example i used “locative” as event and “rocohome” as tag.
The url should look like this then:

https://Homey-cloud-ID.connect.athom.com/api/manager/logic/webhook/locative?tag=rocohome

Your Homey Cloud ID can be found here.

We can also fill in an url for “Trigger on Departure” ofc, works the same way but with a different tag.

Making some flows
Now it’s time to make some flows to do something with the webhooks we get. I’ll explain 1 flow, rest should be doable me guess.

The WHEN part
Flow starts with a logic card (build-in in Homey) and we choose “A webhook has been recieved”.

webhook1

With event we fill in the event we are triggering on, in my case this is “locative”

webhook2

The AND part
For the AND part we pick a logic card again and choose “Is exactly”.

logic1

After that we click the tag thingie with the ? in it and we choose the “tag” tag on the top where it says “In this flow” .

logic2

For the txt from that tag we choose what we filled in in the IOS app. In my case this is “rocohome”

logic3

The THEN part
For this part you can choose whatever you like ofcourse.

Hope you enjoy using this app and please let us know your findings in this topic.

7 Likes

Reserved

Great @Rocodamelshe, looking forward to play with this. However the urls are wrong, the “&tag=” should be “?tag=” :wink:

That will be correct! Dunno how it got there but changed it, thnx

On a lazy sunday I will give this a go. Hope this will make presence detection better. At this moment presence detection is not as accurate as I want(tried homey, nest and fing presence). Only slight problem is I don’t know nothing about webhooks and GET requests😄. Thx;-)

And there for is this explanation ofc. :wink:

Tested this on my way home today and seems to work very well. Problem is, almost all location solutions work initially and stop working after a little while. So too early to tell if this will be more reliable or not.

@Rocodamelshe Have you been using this solution for a while already, i.e. are you able to comment on reliability of a longer period?

Using it for like 4 days now so cannot answer that yet. Made 2 geofences and they both work like they should for those 4 days.

Should the cloud id in the locative app be with or without the ” marks?
Like ”xxxxxxx”

Do “we” think this way will work for a while?

PLEASE NOTE: As announced in https://blog.locative.io/bye-everyone-df01871fe949 I’ve shut down my.locative.io effectively 14th of May 2017. This app will remain in the App Store for reference reasons but won’t ben further supported. Please look at https://github.com/LocativeHQ for its Source Code.

Seem to be a good and easy way to do presence though.

Just curious, how did you find “locative” in the app I don’t fiend anything pointing to that. Is that some kind off standard search string? I did manage, quit easely, your tutorial. So it is “Monkey proof”.:wink:

Not sure what u mean. Like how did i find it in the app-store or?

No, you use the term locative. How do you know that?

Still confused. The app is called Locative so i used it in the examples. U can replace locative in the above examples with whatever u like as long as u use the same replacements in the flows.
U send a webhook in the locative IOS app with /locative?tag=tag.
Can also be /amstel?tag=tag as long as u use the same eventname in the Homey flows.

Cloud ID is without the quote marks.

Ah now it makes sense.

I can’t it to work, i think i’ve done all the correct settings. Anyone else having problems.
I’ve set up flows for both me and my gf, none work.

In the settings part there is an option to test the webhook. Can u test that to rule some things out?

Hmm, where? Can’t find it

U greyed out URL? What should i put in there?