Homey Community Forum

Nest + Homey = Dead API by 31th August

Please keep the conversation in English.

1 Like

Everybody Please note the following:

The nest intergration with “Works with Nest” is now intergrated in “Works with Google”.

Developpers needs only to use the “Works with Google” API instead of the now depricated “Works with Nest” API!!!
Google did not STOP Nest intergration they only moved it to the Google ecosystem.

The Homey App for Nest products needs only to be re-written to use the “Works with Google” API.

There is plenty of information on the Google Developpers site about this.

1 Like

yeah, the problem is getting the permission to use the API, they made it very difficult to get an API key, and even if you get it, they will give a lot of rules, more then there already were with NEST itself.

Allright, but rules are not always bad.
They make these rules to prevent misusing functions in privacy sensitive devices like home control devices. Bad use of some of these API calls can lead to serious security risks.
These rules are not so strict that nobody can get an API key at all.

i’m curious how it will evolve… hope someone can create a app with the google api and see the difference.

Hoe verander je die api?

First you wil have to get a API-key for the “Works with Google” API. On the developer site from Google you can find all the information and tools to use this for developing 3rth party software for Nest products.

Once i was migrated, I was able to integrade the NEST with Alexa.

Anyone else having problems with Nest Protect?

  • Added protect before 31 august
  • Now I am getting the error message ‘This device is no longer available in your nest account’
  • When I do configure app, I need to login to Works with Nest, and I can accept the terms (but it gives an error message)
  • My Nest account is NOT migrated to google.
  • My Nest account still shows Homey as authenticated

I think I can’t reinstall the Nest App on Homey (cant find it in the athom store anymore :()

I saw the same error. restarting the APP and Homey resolved it for me

App restart, homey restart, nothing works.
The app states that I logged out from nest.
When I trie to log in thrue the app, I get to the rights request page, and when hitting confirm I get a general error.
When I log into the nest page itself in a browser, I can login normaly and everything works great.

There whent my therostate support…
Not planning to replace my nest with another thermostate as we do not know when a new brand will stop working with Homey.

All and all this is another dissapointment in Homey. They are stacking up…

This has nothing to do with Homey, as the title already states, since August 31 the Api used by the thermostat has been shutdown, not just Homey has this, every controller has this (IFTTT and Logitech Harmony as example of big brands).
If you want to blame a company, blame Google Nest :wink:
They will try to do more and more things to get people to their own platform, and this is one of those things.

Sorry, but I do not agree with you.
Indeed Google has moved there nest-api to the Google enviroment, but they have the same functionality in there google-api.
So thay state that the thermostate can still be controled using there api. Just that Athom is not using there api.

If I were to change my thermostate now to a deferent brand, who will say that that new brand will stop support for homey. Need to change again?

In short, Athom needs to move the Nest api to use the Google api.

Correction, they first need the permission of Google to be able to use the Google Nest api, until now none of the big companies has gotten this.

Define “big companies”?
Apparently Amazon still has it, as I can still control the Nest with my Echo devices.

I already mentioned 2, they all still use the old api, I can still control my nest too with Homey, so no surprise there that sometimes it does work.

My nest thermostat still works. I did exactly nothing and everything is still working fine up till right now? What did you do to make it no longer works?

Literally nothing.
Used the app to set the temperature, and tried to do the same thing the next day, and Homey sayed there was no device “nest” in my account.
Red explination mark in the icon of the nest, and no longer able to re-login to the device.
Alll other apps still work. (Alexa, IFTT, and Nest itself).

Have you restart the Nest app? A couple of days ago my Nest also don’t work anymore but after a restart of the app everything works back again.